Virtual Machine install problem

I want to install Rockstor in a VM on my Ubuntu 20.04 system to see how it works. I followed a guide which had me install and use Virt-Manager. I went through enabling storage , assigning 2GB of memory and 2 CPUs, then it showed me config and I started the install from the ISO. It soon stopped showing the list of errors massages in the screenshot below (not sure if I uploaded it properly.


I have no idea what the messages are about. Any advice welcome.

OK, I logged out and logged in again, followed the guide for installing the Rockstar 3.9.1 ISO, and it appears to complete OK. But nothing is happening. one screenshot says it is running, the other shows the Graphic Console Spice which say “No bootable device”.


I’ve never used;

Also it sounds like that you don’t have much experience with Virtual machines.

The first screen shot of QEMU/KVM appears to be problems regarding your Virtual Computer configuration.

Just to explain, the “It’s running” message is regarding the virtual hardware to run your machine is switched on.

Hence you have not installed anything regarding Rockstor.

Also please see the posts about installing on OpenSUSE

Since you are new to Virtual machines, Find a guide about installing OpenSUSE as a VM on your box.
Once that is working, follow the instructions on the two forum posts linked to get it going. (Otherwise you could wait a few weeks until the new Open SUSE installer ISO is ready)

Thanks b8two. I have only ever used Windows (until 2000 when I escaped the corporate environment and switched) and macOS. I’m taking a Linux course and have Ubuntu 20.04 on my system but I’m very light on. I wasn’t aware the switch to openSUSE had occurred.

I will follow your advice about openSUSE as a VM. But I see only one forum link about the 3.9.2-59 Beta. Was there another?

BTW, I found KVM Virt-manager a bit uninformative, so I’m planning to install VirtualBox.

I was excited when I found out about Rockstor as I’m very keen on BTRFS.

@ceh-u Welcome the the Rockstor community.

We do have the following virt manager based install guide, just to experiment with Rockstor:

That uses our soon to be legacy CentOS installer (now over 2.5 years old) but may help with your current issues on the KVM side. And as @b8two points out it looks like you have a KVM config issue of sorts. So that guide may help with getting that sorted.

quote=“ceh-u, post:4, topic:7172”]
I wasn’t aware the switch to openSUSE had occurred.

It hasn’t. But we do have beta rpms out. So as @b8two indicates, if you jump through a good few steps, as we haven’t yet released the installer, then you can try out the those beta rpms. Our public beta installer should be released fairly soon though. And likely we will be releasing the way it’s build sooner still. So keep an eye out on the forum for that also.

Best test base to use if you fancy helping with the testing channel rpms is Leap 15.2 RC as our intended release is to be based on that once it’s left release candidate status.
But that’s a fairly massive install image. And if you are only trialing in KVM say you could just start with the JeOS KVM image:

And given your obviously interested in the ins and outs of linux itself then I think I agree with @b8two here and would suggest you give the testing channel approach a go. It’s still not a beginners thing but there are now quite a few folks on the forum who have jumped through the hoops already that should be able to help if you get stuck. Plus the above suggestion of starting with a JeOS KVM image of Leap 15.2 RC may help with speed in playing around in a KVM first. Also if you do find bugs in the resulting install, once your sorted on the hoops thing. Then do fee free to bring them up on the forum as we need all the reports we can get. But note that 3.9.2-60 will have some detached disk fixes included so I’d hold of on reporting detached disk issues until at least that’s out and your have updated and re-tested.

Just be sure to specify which repo you are installing the test rpms into when you do any forum posts as our openSUSE testing channel is now moving ahead of our CentOS stable channel ready for our Rockstor 4 relaunch in the ‘Build on openSUSE’ guise.

Hope that helps. Oh and I’d stick with KVM if I were you, as it’s default in all linux distros and once you get the hand of it it’s super capable. And if you do get stuck in there with anything that seems silly do post a picture with what you are stuck on as tons of folks use the KVM / Virtual Machine Manager combination and much of Rockstor is developed on it. Just remember to give virtio disks serial, or use SATA, again that howto should help on that front and still worth working through that to identify what went wrong with your original attempt. But probably best, especially if you are interested, to then have a go at the JeOS KVM image, doing the various indicated config required, then installing the rpm and taking the testing rpm for a spin.

1 Like

Hi - thank you very much. Reading all of this more closely, and realising that the releases are rpms, I think the best approach for me is to replace my Ubuntu build with Leap 15.2. The only reason I have Ubuntu is that I needed a build for the Linux course and Ubuntu was easy.
So I’ll get the Leap 15.2 RC and use that as my base.

@ceh-u Re:

So from this I’m assuming your currently have Ubuntu installed on your current test hardware for the NAS. In which case yes you will need a Leap 15.2 RC server install ideally. But if you are referencing your desktop then that can be what ever really.

Apologies if I have the wrong end of the stick here. Ubuntu does make for a nice desktop client OS. I have it on several laptops myself. But my main development Desktop is openSUSE Leap.

So in short don’t install the rockstor rpms directly on your desktop. This is highly ill advised. They are mean to transition a Leap 15.2 RC server install to a NAS appliance install. But you can trial the whole Leap 15.2 install thing in a VM on any desktop OS and then make the changes to that VM install of Leap to change it to a Rocsktor appliance via the teaks (hoop jumping) and the testing rpm install.

The problem with installing the rpm directly into a desktop/laptop OS is that reaches out into all parts of the OS to modify them for our purpose to turn the machine into a NAS. That will not play nicely with a desktop at all.

Hope that helps and that I havn’t gotten the wrong end of the stick on that. Plus I think Ubuntu probably makes for a more friendly desktop currently. Although the boot to snapshot rollback in openSUSE is nice.

1 Like

HI Phil – Until I can complete my NAS hardware build, you are right – I will be testing on my desktop. My Linux installs go on a 240GB SSD attached to my Asrock z270 system. I don’t have the extra HDs I would need for a full trial of Reckstor. So my trial Rockstor installs will have to be on VMs.

After the post you replied to, I checked with a friend who told me that openSUSE Leap 15.2 is really heavy duty compared with Ubuntu. If I installed Leap 15.2 on my desktop, I would then need to install it again in a VM to host Rockstor. So, my understanding from your advice is that I should setup a VM on Ubuntu, install Leap 15.2 as minimally as possible in that VM, then install Rockstor rpms from within that Leap. Is that OK?

I see openSUSE has a much smaller Network image which can be configured for a smaller footprint. If that’s OK I’ll install that on a VM on Ubuntu, then install a Rockstor rpm within that. Hope i’m not oversimplifying things.

I really appreciate your advice.

1 Like


I’d agree with that, especially if a little new to linux. But it’s getting more friendly as it goes along. Plus there’s no point in changing your Ubuntu install just for this project.

Yes that pretty much it. And for a minimal KVM install you could just use the openSUSE provided pre-installed virtual machine images here on the JeOS tab:

Then, as these images are pre-installed system disk images, when you create the new VM instance you select the downloaded image as the system disk and it boot straight from it. No install required. Super fast to setup and much smaller to work with.

Not sure which you would use for Virtual Box but for KVM there is a “KVM and XEN” option. Only 250 MB’s or so also so that’s handy.

Just select it as a disk image during VM setup. I.e. in Virtual Machine Manager:




In the following I just edit the name to make it clearer what it is.


It should then just boot that pre-installed image and will ask country keyboard questions as a first boot thing and then:

You then only need to make sure, before doing the Rockstor tweaks and rpm install that you give the drive a ‘real’ serial number: i.e. via:

Apply that and on next reboot that drive will have a serial number which all real drives do and Rockstor needs. So best get that done before you do the necessary configs tweaks and before rockstor testing rpm repo add and install.

Also if you do end up having space to add some data disks to play with pools I’d not go lower that 5 GB each. 10 GB each is preferred. Btrfs does things in chunks of 1 GB so that’s only 10 units per drive with the higher minimum figure. Our guide I referenced earlier uses a way to low number so we will have to change that but that can be done for our new installer which isn’t much different from this install anyway really.

Hope that helps. And remember that instance will only, by default, be accessible to the machine it’s installed on. So not accessible via the lan without some more network config. But enough to get a working experimental system setup.

1 Like

That is fantastically helpful. I’ll certainly follow the approach you detailed. Many thanks - you are making it very easy. I won’t need any Lan access. I want to see how the install goes and and how your system works. By the time I’ve done that with your recent releases, I should have my NAS build ready for software.

1 Like

I have installed the JeOS Leap 15.2 image, and it has come to the localhost login: During the setup I wasn’t asked to create a user Id, so I’m afraid I have to ask what Id I would use. I tried the user Id I have for Ubuntu but that’s obviously not it. I can’t see anything on the openSUSE guide that deals with this. I tried the root password but that just produces a loclahost prompt in red. Displaying my Linux ignorance here!

OK I found material online ( that indicates, after the initial install (for which he user VirtualBox) I should start creating a new VM in VMW, tell that I will install the OS later, do setting up of the VM processors, etc., then when setting up the disk say to choose an exiting virtual disk, and finish. Once the setup finishes (time zone), log in as root and run Zypper update to check everything’s OK. Seems very complicated, but is that the way to go? I assume after all that it reboots to the GUI.

@ceh-u Hello again.

Well done. You now have a JeOS (Just enough Operating System) install of Leap 15.2 RC. There is nothing more to do to install wise for the base Leap install. That was what I meant by the pre-installed.

Not really as you have done all this already. The JeOS image you downloaded had all updates installed already and you have already added the system drive etc by way of using the qcow2 image. So I think the confusion here is that there is not GUI in this sort of install because it’s bare bones. This makes it great for building appliances and server based system on as they typically don’t have GUI. But have only CLI Command Line Interfaces. The localhost login: that you saw was a linux command line interface login.

That’s another part of these minimal installs. There is only the ‘root’ user, although a typical linux system acutaly has many users for various descrete elements of the system but they all set themselves up. But from the login point of view there is only the root user.

So when you went through the initial steps in booting that pre-installed JeOS disk image you were asked to provide a password. That was the ‘root’ users password. So you can now login using the username root (then enter key) and the password (then enter key); and you should then be active as the root user in your new JeOS Leap 15.2 RC install. This is the linux command line. Rockstor, once installed, provides a Web-UI that is accessible over the network and you can add users, btrfs pools etc using that interface. But to do the rest of the config changes to this bare bones Leap 15.2 RC install you need only the root user. But remember that root is all powerful so you can break anything and everything with that user. But still, you can always just repeat what you have done to get back to here.

Hope that helps and let us know if you are able to login as root. I’ve actually done a Howto for our new installer which covers some of this stuff. But given you are engaged in a linux course I think the base preperation prior to putting in the rockstor rpm will be of general use / interest. Not really for beginners but entirely doable with patience. And you can always post here.

So in short your next step, given you have a fully updated and functional Leap 15.2 RC booting within your KVM setup is to look to the command line actions required to pre-configure this base install ready for it to be finaly modified by the rockstor rpm to become a Rockstor appliance install.

Do say if I’ve miss-understood your stage in all of this but I think the GUI missing element and the unfamiliarity of virtual machine use and what a linux command line only boot up looks like has distracted you. There is not GUI element of Rockstor or a JeOS install, only a Web-UI which is not there until you do the final rpm instal.

You might be best to install the nano editor first, I would say, as you are likely unfamiliar with vim which is notoriously unfriendly but available on all linux distros by default, including these super cut down JeOS installs.

zypper in --no-recommends nano

We use “–no-recommends” here to avoid dragging “recommended” extras in as well. This keeps the install minimal and small. Then there is only what we need.

Then you will have the nano editor at your command to do any file editing, and there is a little of this comming. It’s more friendly than “vim” (newer vi) as it has on screen instructions. I use it all the time.

Hope that helps. And yes you can update via the command line but given the RC status of this particular install and caveates attached to that we can skip this for now. Plus as of when you downloaded it, it was fully updated which is nice. And you are only gaining familiarity with the CLI and the required steps, currently, to try out our testing release at the moment. When our installer is released all that you are about to do, and more, is done for you. But it’s still good, and interesting, to know how we differ from our upstream Leap 15.2 JeOS base.

Let us know how you get on. And by the way Digital Ocean uses KVM to provide their base service of virtual machines on demand, not virtual box: just saying :slight_smile: . So you have now used the exact same technology to ‘stand up’ your first Leap 15.2 RC install.

This will all become far clearer as you establish the boundaries of the various ‘involved’ technologies. But for now you look to have a working linux VM wihin your Ubuntu desktop OS.

OK, amazed at how much time you are spending on this.I logged in as root, and I assume nano should be installed in the JeOS. Anyway, as the attached screenshot shows, first the connection failed, I checked in KVM that it shows Autoconnect and it was showing some CPU activity. Virtual Networks looks OK (see screenshot). So I don’t no whats going wrong. It does seem to indicate finding no valid metadata in the repository.
Anyway, one step forward! :neutral_face:

OOPS! Screenshots.

@ceh-u As you suspect, this looks just like there’s no internet available for the guest machine.

If there was then you should be able to ping that address:

localhost:~ # ping -c 3
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=52 time=23.8 ms
64 bytes from ( icmp_seq=2 ttl=52 time=25.0 ms
64 bytes from ( icmp_seq=3 ttl=52 time=25.9 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 23.891/24.969/25.946/0.861 ms

So that’s the next place to look, diasnosing why the guest machine has not internet access when the host presumably does. This is independent of Rockstor so you may well find the answer more easily elsewhere. Unless other forum members can chip in to suggest what might be failing here. But you will of course need internet access and it’s usually available by default within a default KVM install such as you appear to have. What is your version of Ubunut by the way? May help with know issues relating to firewall or network settings or the like. But I’ve not seen this myself.

Let us know when you’ve got that sorted though. And the above ping was from inside my parallel install from what is presumably the same install image.

You could double check if the NIC setting in your particular VM is configured to use the Default Virtual Network you have indicated. What you have shown is the overall KVM network setting. You need to check if the NIC is actually part of that network. It normally is by default but worth a look:


Hope that helps. I’d better go do some Rockstor dev for a bit actually :slight_smile: .

@ceh-u Quck update:

Although when I tried the same address as indicated as failing for your zypper it worked. Funnily enough it may be that they are having issues, and it had yet to reach me (in UK) as when I now do the same:

ping -c 3

--- ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2001ms

There is not response. This is both good, that it may not be your setup, and bad, in that it’s openSUSE’s. Oh well. I’d give it some time and try again as I know they are making some major changes to their infrastructure so this may just be downtime (planned or otherwise) that we only affected me a little later than you.

Yet if one ping say google:

ping -c 3
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=115 time=13.5 ms
64 bytes from ( icmp_seq=2 ttl=115 time=46.8 ms
64 bytes from ( icmp_seq=3 ttl=115 time=12.2 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 12.243/24.193/46.833/16.017 ms

Might be worth just trying that in your VM to narrow down if this is an opensuse server issue and your own network is just dandy?

Incidentally, in the time I’ve noticed this I’m now able to ping said problem address again:

ping -c 3
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=52 time=31.9 ms
64 bytes from ( icmp_seq=2 ttl=52 time=26.8 ms
64 bytes from ( icmp_seq=3 ttl=52 time=25.5 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 25.567/28.119/31.920/2.746 ms

So does look to be intermittent. Give that zypper command another go. Should still be in your command history via the up-arrow.

Hope that helps.

@ceh-u Re:

From the openSUSE side of things looks to be OK. I wonder if this is another ‘internet poorly’ day. How did the ping diagnosis go by the way?

Afraid no luck. The VMM CPU & Network I/O graph seems to show activity. Also the machine details for the NIC look OK but IP address unknown. I can ping openSUSE from my Ubuntu but from the JeOS i constantly get “Temporary failure in name resolution”.
I’m out of my depth on this stuff but I try to find sources of troubleshooting advice. I’m done for today.


I changed from a Wi-Fi network connection in case that was a factor. The VM itself seems fine, apart form the boot message:“pciehp: failed to check link status”.
But online research indicates that has to do with stuff like BIOS setting for hot swapping.
The NIC setting looks OK. I did try changing the device model to e1000 but no change.

The host Ubuntu network setting also looks OK, and Internet access there is fine.
So I’m stumped. Probably something to do with my desktop system. I’ll probably have to wait till I have my NAS hardware before I do any more testing.