Windows 10 File Explorer Mis-Counts NAS folders/files

I have run into a nasty problem that I can’t solve. YES I have searched the internet and applied all fixes but they have no effect.

Win10 insists on mis-counting or somehow ignoring things in a random sort of way when reading a shared NAS drive.

I suspect Samba bug or something and wonder if any Gurus could help.

Here is the simplest example I have found:

(Open pic in new tab to get full size)

xfrh1

Nothing I do seems to fix the problem. Windows doesn’t count the files under Werner… but the exact copy of this directory on a local drive works fine.

xfrh2

HELP!

:sunglasses:

That’s a pain, however I do remember having something similar a few years back, with another NAS solution. I’m sorry I cannot be 100% sure but for some reason I think it was connected to permissions - not just at the SAMBA level but also at the filesystem level.

If it comes back to me I will update here.

EDIT: And just to not help any further (sorry) I have checked a similar thing using my wife’s W10 laptop and it is fine. My laptops are all Linux, and are also fine. Sorry that doesn’t help, but just confirming from my end.

1 Like

I think this may have something to do with the last windows update because I haven’t seen it before over the last few months.

There was a problem with long files name circa 2018/2019 that required a registry mod and group permissions changes for overly long file names. There were a couple other small items related to Home vs. Pro Win10 versions as well regarding indexing glitches…

Interestingly enough, using a CLI compare and DirCmp app, all the files seem to be there, it’s simply File Explorer is messing up.

This means I can continue to rely on the system as is and not worry about the files counts since Copy/Paste etc. all seem to work as expected.

It is however very annoying.

:sunglasses:

PS: Windows 7 works fine. Go figure.

3 Likes