Anonymous guest access using SMB


I’m new to Rockstor and I’ve been trying to figure out how to enable two things:
1- Making my Rockstor server visible and accessible from Windows by browsing through the “Network” functionality
2- Creating a read-only local anonymous guest access, for users to browse the server without account and login

The goal is for anyone in the house to be able to access data without having to type the server’s IP address or to have a preset account.

I haven’t found my answers browsing through the forum, or going through the docs. Does anyone have pointers?

@Dahita Hello there.

The key areas here are:
Samba: Services — Rockstor documentation

Which then suggests the following sections:

You can now proceed to Create a Samba Export of a Share and access shares from clients.

Likely getting the WORKGROUP correct, and using guest access should do it for you. There can be issues with network discovery which the following Rock-on was intended to address:

“Web Services Discovery Daemon (Wsdd) rockon #294
added by @Hooverdan.

But make sure everything else is in order first before using the Rock-on as it may just not pertain to your requirement here.

Note that there are others here on the forum far more knowledgable than myself on the Samba front so do hang in there for further advice on this one.

Hope that helps.


Hi @Dahita,

@phillxnet pretty much already laid it all out but I wanted to provide some more details.

With regards to seeing your Rockstor NAS in the Network section in Windows Explorer, you will indeed need Wsdd; this is unfortunately needed now due to some changes unrelated to Rockstor that made the automatic discovery of Samba share across a network requiring this additional piece of software. Thanks to @Hooverdan, though, the Rock-On they made is very simple and efficient!

With regards to making your Samba export read only, I would point you towards the corresponding option when you create a new Samba Export in Rockstor. See the related section of our docs linked below for more details:

Hope this helps!


Thank you both so much for your answers, it was very useful. I’ve got the RockStor visible from guest computers through the Rocks-On Wsdd install and it was a real breeze!

The one area I’m still struggling with is the anonymous guest access. In my Samba export, I had made myself “Dahita” as an admin user, and checked that the folder is Browsable, with Guests ok, Read Only as “yes” (thinking it wouldn’t apply to me as an admin). However, the Read Only applied to me (impossible to transfer files, being logged in as Dahita), and any other computer couldn’t access the server using its ip address.

Turning back off Read Only, I could transfer my files but I’d still not have any guest access, and even if I did, I wouldn’t want them to be able to add/delete anything. That’s the part I couldn’t figure out from the docs initially, using the “media_user” example.

So now at least I’ve got the server visible, but still no access from guests. Is there something glaring that I’m missing?

Edit: In my Samba log all I see every time I try to connect from a guest laptop is:
[2023/01/30 13:22:04.998152, 2] …/…/source3/lib/tallocmsg.c:84(register_msg_pool_usage)
[2023/01/30 13:22:04.998798, 2] …/…/source3/smbd/server.c:816(remove_child_pid)
Could not find child 6438 – ignoring

I’m looking into it :slight_smile:

Edit 2: I’m realizing I don’t have access to the WebUI from guest laptop using the ip address, like I do on my main computer. The connection is refused. Same from my Nvidia Shield when trying to connect through SMB protocol + IP, “Connection refused”. Thus I’m discarding the SMB access problem for now to look into a more global issue. Strange that I see the Wsdd in Windows Network, yet I can’t access anything. I do have access to other shares from different computers on the network, so I don’t think the issue comes from my LAN.

1 Like

@Dahita, I assume, that’s not the issue, but I think I better ask in case it turns out to be. For your WebUI access, you are using the https:// version of the IP, correct?


Thank you for not sparing me the easy questions, I actually did not use the HTTPS to connect. That solved it from the guest laptop for the WebUI access!

Also, I can map a network drive from the guest laptop and access the files without logging in. I do not have write permissions, regardless of the Samba parameters for guests, but I’m assuming it’s because it’s not using this protocol to map the drive.

However, I still cannot access anything from the \Rockstor location in “Network” section under windows 11 from the guest laptop.

Still running tests…


Hi @Dahita,

Let us know how your tests go… In case you haven’t already, I would try to see if you can replicate the example detailed in our docs:

Once we have that cleared, we can work on getting your needs working.

Good luck!


Just a thought:

Would introducing mDNS with Avahi not help with discovery? If it is set to use the hostname of the machine then any device that support Bonjour service… which these days is just about everything, should be able to find the machine using it’s name.

1 Like

Interesting… we do have the Avahi service running as we use it to advertise a Samba export to Mac machines in search of a TimeMachine-compatible share.
If I remember correctly, old versions of Rockstor used to use Avahi to advertise Samba exports too, but it was removed for a reason that eludes me for the moment; one would have to do some git history spelunking for that.

Now, I seem to remember that the issue with Windows not seeing Samba “servers” automatically anymore was not something that Avahi could fix, although I would love to proven wrong. @Hooverdan, you most likely know more than me on that one so please correct me if I’m wrong. I seem to remember that it was due to the deprecation of a certain protocol by Microsoft that the wsdd re-instates… or something like that.

1 Like

Yes, in the past the issue was because of some deprecation on the windows side (starting in Win 10). Here is a thread where we discussed this (before we got the wsdd Rockon):

Incidentally, I still have the same smb settings though I have not investigated whether I could get rid of them or not (don’t touch a working system)