Dev log for upcoming 3.8-10

Hello Everyone,

It’s great to see increased activity in the forum. Thanks to all of you that are actively using Rockstor and reporting bugs, requesting features and offering ideas. And also thanks to those buying Stable subscriptions! Please keep them coming.

The development work for 3.8-10 has started and the first Testing update(3.8-9.01) is now available. There are two main issues we’d like to address in this cycle. (1) Replication and (2) Rock-ons. We will undoubtedly close several other smaller issues along the way. Just like 3.8-9 cycle, the plan is to work towards reaching the current milestone(Tuolumne). We closed 26 issues so far, and there are 23 more left.

For the 3.8-9.01 update, I’ve managed to fix regressions in Replication code. Things are back to a working state, but we need to simplify the interface, make it more robust and test thoroughly. Those of you eager to try out replication, please give it a try and offer your feedback. But keep in mind that there could be a couple more pull requests before the following issue can be closed.

Secondly, @mchakravartula added a bunch of new tests improving the test coverage.

Finally, the kernel is updated to 4.2.5. There are several new btrfs changes since 4.2.2 and I am hoping that next few weeks of testing will yield good results.

sounds great, keep up the good work :smile:
eagerly awaiting the docker improvements :wink:

3.8-9.02 Testing update is now available. We’ve managed to push another batch of replication improvements. Building on the last update, I’ve focused on functional improvements and thing are looking reasonable in my testing so far. I encourage those interested in Replication to test out this update and report issues.

In addition to replication changes, the update also contains some UI enhancements, thanks to @ganti_priya.

Finally, I’ve received several e-mails about 3.8-9 iso failing on setup when installed with multiple network interfaces. The bug is now fixed and it doesn’t effect existing installs. But I’ve also created the 3.8-9.02 ISO file for new installs. This is exceptional, but since more than a few users ran into this issue, I’ve created the ISO.

1 Like

3.8-9.03 Testing update in now available. The focus remains to be the replication feature, but we’ve also managed to merge a few more pull requests. I am thrilled to have merged a pull request for UI improvements from a new contributor @grogi

I may have one or two more installments for replication(#886), it’s been a very exciting dev->test cycle so far. I do encourage those of you interested in replication to give this update a try.

Here’s the log for this update

It’s a bit unusual that we haven’t had a Testing update in 9 days, but finally, 3.8-9.06 update is available. We’ve improved test coverage, enhanced the UI a little and improved replication, the main theme of this release cycle.

The reason it took a bit longer is that, even though focus was mostly on improving replication(#886), we paid off some technical debt by updating opensource libraries we depend on that proved to be useful for present issues and beyond. This is a familiar occurrence every few months and even though it delays our development, I am very grateful to the opensource community for the benefits we all get from these updates.

I am 100% sure there will be another testing update before the Stable(3.8-10) and about 80% sure there won’t be another one after that. Anyway, here’s dev log for this update.

Thanks to @ganti_priya for the new switch implementation on the UI.

Thanks to @mchakravartula for yet another pull request for improved test coverage minor bugfixes.

Don’t know what went wrong, but all my Samba shares stopped working after updating to this.

I had to delete them and recreate them, to gain access.

No major hurdle, but had me wondering what had gone wrong :smile:

That is very strange. I’ll try to reproduce it, but it would help to have more information. Was the samba service running after the update? Was the machine rebooted? Are you able to reproduce the problem?

The machine asked to be rebooted after update, because of a new kernel.
The samba service was running.

After the reboot, I couldn’t access the shares. Or more correctly I could, they just showed up as empty. I tried removing them and adding them again in Windows, no luck. Rebooted windows, no luck.

All the shares showed up as empty with 11Gb of space available.

Removing them in Rockstor GUI and adding them again restored access to files immediately, and everything works now.

Ok, that makes more sense now. If you are willing, you could perhaps reproduce it by rebooting your machine again. As part of bootup, the rockstor-bootstrap service runs towards the end, which mounts Shares required for Samba. Either there is a bug there due to which mounting fails or samba is letting users in a bit too early, hence the empty directories. When you recreate samba exports, it does a fresh mount and that seems to be succeeding.

I’ll try to reproduce it, thanks @KarstenV as always! Please do report any other problems you notice.

Well, it seems my NFS share is not working either. I cant get my Kodi machine to connect via NFS no matter what.

And that has allways worked flawlessly.

Has tried removing and adding the NFS share, and rebooting the Kodi machine, but it sinply does not see the NFS share anymore.

Any ideas?

I suspect that Shares are not being mounted properly. Can you send logs to support@rockstor.com?

Can you remind me of the steps to do that?

Edit: I think you are right, a reboot broke Samba also once again.

This is something that needs fixing ASAP :slight_smile:

Since my media center is relying on NFS working, I had to become a litle bit creative.

I turned of both NFS and Samba services in the GUI, asked Rockstor to reboot, with them disabled.

After reboot, I waited a couple minutes, and then re-enabled both.

Now I have both Samba and NFS access.

2 Likes

Well, I found / experienced another error.

Trying to see SMART data for my disks, when hitting refresh on the disk, I get an error saying:

Error!

local variable ‘capabilities’ referenced before assignment

The error is present on all disks in the NAS. When I hit refresh to get updated data, it errors out.

Thanks @KarstenV, i noticed that too. I wished to have released an update with fixes by now, but things are bit slow due to Thanksgiving holiday here. But I’ll push the update soon!

1 Like

~ ᐅ systemctl status -l smb
smb.service - Samba SMB Daemon
Loaded: loaded (/etc/systemd/system/smb.service; enabled)
Active: inactive (dead)

Nov 28 20:09:10 rockstor systemd[1]: Dependency failed for Samba SMB Daemon.

~ ᐅ systemctl list-dependencies smb
smb.service
├─rockstor-bootstrap.service
├─system.slice
└─basic.target

~ ᐅ systemctl status -l rockstor-bootstrap.service
rockstor-bootstrap.service - Rockstor bootstrapping tasks
Loaded: loaded (/etc/systemd/system/rockstor-bootstrap.service; enabled)
Active: failed (Result: exit-code) since Sat 2015-11-28 20:09:10 CST; 48min ago
Process: 2234 ExecStart=/opt/rockstor/bin/bootstrap (code=exited, status=1/FAILURE)
Main PID: 2234 (code=exited, status=1/FAILURE)
CGroup: /system.slice/rockstor-bootstrap.service

Nov 28 20:09:10 rockstor bootstrap[2234]: File “/opt/rockstor/src/rockstor/scripts/bootstrap.py”, line 43, in main
Nov 28 20:09:10 rockstor bootstrap[2234]: aw.api_call(‘network’)
Nov 28 20:09:10 rockstor bootstrap[2234]: File “/opt/rockstor/src/rockstor/cli/api_wrapper.py”, line 85, in api_call
Nov 28 20:09:10 rockstor bootstrap[2234]: self.set_token()
Nov 28 20:09:10 rockstor bootstrap[2234]: File “/opt/rockstor/src/rockstor/cli/api_wrapper.py”, line 79, in set_token
Nov 28 20:09:10 rockstor bootstrap[2234]: raise Exception(msg)
Nov 28 20:09:10 rockstor bootstrap[2234]: Exception: Exception while setting access_token for url(https://192.168.2.2): HTTPSConnectionPool(host=‘192.168.2.2’, port=443): Max retries exceeded with url: /o/token/ (Caused by <class ‘socket.error’>: [Errno 111] Connection refused). content: None
Nov 28 20:09:10 rockstor systemd[1]: rockstor-bootstrap.service: main process exited, code=exited, status=1/FAILURE
Nov 28 20:09:10 rockstor systemd[1]: Failed to start Rockstor bootstrapping tasks.
Nov 28 20:09:10 rockstor systemd[1]: Unit rockstor-bootstrap.service entered failed state.

I’m experiencing the same issue. SMB shares all register as blank after update and reboot. Seems it’s a known issue, but just wanted to make sure it was posted somewhere. I’ll recreate my shares and won’t reboot for now.

Thanks guys!

Thanks @forrest_xu. @roweryan has also reported this problem in this issue. I am working on it right now and will push out an update today. I am putting in a retry logic as the root cause for set_token problem is elusive atm.

Thanks again @KarstenV. Fix is committed. Should be rolled out with the testing update later today.