Error during repo refresh

Brief description of the problem

When trying to update or refresh through the System Shell, I get the following error

Repository 'Rockstor-Stable' is invalid.
tc/zypp/credentials.d/Rockstor-Stable&auth=basic] Valid metadata not found at specified URL
[Rockstor-Stable|http://<myapplianceid> /leap/15.4?credentials
=/etc/zypp/credentials.d/Rockstor-Stable&auth=basic] Repository type can't be determined.
Please check if the URIs defined for this repository are pointing to a valid repository.                                       
Skipping repository 'Rockstor-Stable' because of the above error.

Detailed step by step instructions to reproduce the problem

Running either of the following commands

zypper up


zypper refresh

Web-UI screenshot

Troubleshooting steps

I’ve only tried removing the repo and switching from stable updates to testing updates, and then back again. Same error occurs

Also censored applianceID as I’m not really sure if that’s even sensitive or not

@QuiveryNut Welcome to the Rockstor community forum.

This one is easy. We have not yet released a Stable rpm (repository) for Leap 15.4, but we are getting there. As of this post we are on our Release Candidate 3 (RC3) in the testing channel, which is also included in our most recent downloadable installers:

And the repo will just be skipped as a result, at least untill it actualy exists, as indicated by the:

We have the following GitHub milestone for our next stable release:

Hope that helps.


@phillxnet that was a huge help, thank you!


When is this due for release? seems that there hasn’t been a stable release for quite some time now.

Hi @marksie1988,

What a good timing!
@phillxnet actually just created the next release in the cycle (Release 4.6.1-0 · rockstor/rockstor-core · GitHub). You can find some additional details in the related issue: Bump versions to a 4.6.1 base (Stable) - master branch · Issue #2615 · rockstor/rockstor-core · GitHub. In there you will see that this next release is planned to be the next Stable channel release is all goes well after a short stay in the testing channel repository as per our usual policy.

1 Like