Error while creating Pools

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

After entering the settings to create a Pool and clicking ‘Submit’ an error message appears (Screenshot)

Detailed step by step instructions to reproduce the problem

I’m in Storage / Pools / Create Pool
I enter the following:
Name: NameOfPool
Raid Configuration: Raid 1
Mount options: none
Select disks: 2 equally sized hdds
Error appears on clicking ‘Submit’

Web-UI screenshot

Error Traceback provided on the Web-UI

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/rest_framework_custom/”, line 41, in _handle_exception
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 445, in post
add_pool(p, dnames)
File “/opt/rockstor/src/rockstor/fs/”, line 146, in add_pool
out, err, rc = run_command(cmd, log=True)
File “/opt/rockstor/src/rockstor/system/”, line 227, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/sbin/mkfs.btrfs -f -d raid1 -m raid1 -L SmallPool /dev/disk/by-id/ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F0SSADRY /dev/disk/by-id/ata-WDC_WD10EZEX-00WN4A0_WD-WMC6Y0H255AU. rc = 1. stdout = ['btrfs-progs v5.14 ', ‘See for more information.’, ‘’, ‘’]. stderr = [‘ERROR: not enough free space to allocate chunk’, ‘’]

I can create pools using single disks without Raid.

Thanks for reading. I appreciate any hints on how to solve this. Don’t hesitate to ask for further info if required.

Ummm, keeping it simple here, I 'm guessing you deleted old pools, then tried to create a new pool?

Did you also delete any internal and external shares of the deleted pools?

Last step to do before creating new Raid-1 would be to click on the carrot thing on the disk to release the old pool data and reformat the drives before the new pool is created.

If all this was done, then the drives can be assigned to a new pool… don’t forget to tell us what version of Rockstor is running…


(I’m just an old user, not expert)
(Sometimes I found a reboot after clearing old disk setups was helpful)

1 Like

Hi Tex and thanks for taking the time to answer.
I’m running a fresh install of Rockstor 4.5.8-0. The relevant drives are 2 brand new units plus 2 hdds rescued from older PCs, wiped and formatted. So no previous pools or shares. Rebooting didn’t help either.
I’m thinking its to do with the

["ERROR: superblock magic doesn't match", 'ERROR: not enough free space to allocate chunk', '']

but I’m afraid I don’t know what to do about that.

PS: Another user with the same issue said they solved it using Rockstor’s built-in wipe. I tried that, but nothing changed.

Okay… well I had some problems back-when with creating pools etc. using 4.5 and 4.6. Those problems seem to have disappeared with 5.0.9.

I would change to testing updates and get 5.0.9 on. It has been working flawlessly since the last update; so much so I finally updated my 4.1.0 NAS to 5.0.9! It was easy and runs perfectly for me.

Could be some weird HD thing like Seagate has going on with their SMART stuff…


PS: Everything got better with 15.4 then 15.5 Leap updates anyways…


Upgrading to 5.0.9 did the trick! Thank you very much!


Cool Beans! Glad I am not totally useless!