Failed to retrieve list of pools from remote appliance

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Failed to retrieve list of pools from remote appliance when trying to create a replication task.

Detailed step by step instructions to reproduce the problem

[write here]

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/smart_manager/views/receiver_pools.py", line 35, in get response = aw.api_call('pools') File "/opt/rockstor/src/rockstor/cli/api_wrapper.py", line 75, in api_call self.set_token() File "/opt/rockstor/src/rockstor/cli/api_wrapper.py", line 69, in set_token raise Exception(msg) Exception: Exception while setting access_token for url(https://rockstor-irc.jbdc.net:443): 'access_token'. content: {u'error': u'invalid_client'}

@kknight Welcome to the Rockstor community.

From you picture it looks like you are running a non updated iso install 3.9.1-0. The testing channel has quite a few more fixes available but for replication you will need to be running a later version of the Stable channel which has very may more fixes in. Including some for the replication system as the testing channel is known to be broken for replication.

Not sure if your exact problem is this but given replication is known to be broken in the testing channel you will need to upgrade to stable channel on both machines for it to work at all. Sorry about that but it is the current ‘state of play’.

The stable channel is also now very much newer than the last released testing channel update. Please see the following thread’s intro for some background on this:

If you don’t fancy the stable channel release then for now at least you will have to forgo the replication feature. But in that case you will still have many benefits from running the last release of the testing channel as there were 16 fixes released on from what you are currently running and the last released testing (3.9.1-16) is equivalent to what would have been our nest stable release, ie 3.9.2-0. But we didn’t end up releasing a new iso (more details in that referenced thread)

Hope that helps.

Thanks for the info. I did some checks on my side and found a dns entry that was pointing to the docker0 ip instead of the enp2s0 ip. I corrected it and was able to retrieve the pool listing for the remote appliance. Replication also worked when I ran a test.

@kknight Hello again,

Nice find on the DNS bit and well done on at least configuring replication; we need to improve out docs on this; but, re:

The replication takes 5 cycles to then settle into a 3 cycle state. You likely have tested only the first cycle.

The fix was introduced in stable channel release 3.9.2-13 Jan 2018.
And the related issue was:


and the consequent fix (by me) was via pr:

Hope that helps.

But on second thoughts the API change that caused the regression:


is down against 3.9.2-0

which is equivalent to 3.9.1-16 so it may be that it was added (the regression) as part of the 3.9.1-x development cycle.
Oh dear, that was rather a long time ago now.

Anyway, so with that in mind, and if replication is a key feature, you may be better to stick with that version, given the later testing updates then broke regressions (if my second attempt here is correct). Let us know if it goes through the full 5 cycles and then settles in. In which case great. But given that code has had > 60 fixes / improvements now (although some regressions of course) you are going to be better off using a couple of stable releases installs but that may not be appropriate.

Hope it works for you and apologies for jumping the gun (possibly) but do note that the code you are running is very old now.

1 Like

That’s ok. This is very interesting. Never knew about the cycles and regression thing. Will do the upgrade later today. Thanks much.

@kknight Re

If you are planning on upgrading to stable, great. But to be clear, on my second attempt in this thread, I suspect the regression that broke testing after 3.9.1-0 was within the now paused testing updates channel. So if you upgrade only within testing channel you may end up breaking replication. But it is fixed again in latest stable.

Sorry I’ve rather muddied the waters here. I’ll bow out while I’m only a little behind. :slight_smile:

Ok…So it’s upgrade to stable or reinstall 3.9.1…sigh