Removing an unplugged USB drive fails with non-existent error

Brief description of the problem

Trying to remove a cleanly removed and unpluged disk from the system throws this error. Not critical by any mean, just annoying

Detailed step by step instructions to reproduce the problem

Used a USB HD during migration from freeNAS to move data between pools (FZS->btrfs) and created a single 6 disk pool where 5 where together in a USB raid box (through port multiplier, disks individually seen) and the one showing the error physically apart, but in the same logical pool. After migrating it got cleanly removed from the pool and it’s no longer connected, but when I try do remove from the GUI the mentioned error pops up

Web-UI screenshot

No info on screen but the attache error

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/storageadmin/views/", line 274, in delete disk = Disk.objects.get(name=dname) File "/opt/rockstor/eggs/Django-1.6.11-py2.7.egg/django/db/models/", line 151, in get return self.get_queryset().get(*args, **kwargs) File "/opt/rockstor/eggs/Django-1.6.11-py2.7.egg/django/db/models/", line 310, in get self.model._meta.object_name) DoesNotExist: Disk matching query does not exist.
1 Like

@AngeleToR I’m pretty sure I know why that is, when a disk is removed and hence flagged via the dustbin / trashcan icon as no longer being attached it’s internal name is essentially regenerated on the fly after every disk scan (every few seconds usually). A simple work around is to hit the “Rescan” button to get a fresh name generated and then shortly there after do the dustbin / trashcan icon removal act.

Hope this helps and we do have an issue open on this ie:-

My fault I’m afraid as when I re-worked an aspect of drive name storage I had to make this compromise in order to fix a greater problem at the time. Hopefully we can sort this out properly in the not too distant future.

Thanks for reporting this and bringing it to light on the Forum.
Also using the new forum template system I see: Fancy :slight_smile:

1 Like

Thank you @phillxnet I’ll give it a go, searched the forum but didn’t find the issue, will look closer next time. Following your instructions worked like a charm. Lesson learned :wink:

1 Like