Rockon Utorrent assistance

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

I have installed the utorrent rockon and downloaded a tv show file, but I can not find where the rockon has stored the file. The setting inside the Webui " Put new downloads in:" doesn’t allow me to save the directory /mnt2/Rock_TV
I’m pretty sure that I’m just missing something but can’t seem to figure this out. I have checked all of the shares and don’t see the file that is currently showing complete.

Detailed step by step instructions to reproduce the problem

Here are the settings that ip used on the rockon.

Web-UI screenshot

Error Traceback provided on the Web-UI don’t think that this applies!

[paste here]

Thank you for any suggestions that anyone might have.

OK I found where it is saving the files. The files are being saved in /mnt2/UtorrentSettings
is that correct? how can I move or redirect those files?
Is it possible to have this Rock-on save the files to another Rockstor device known to the device in use?

Hi @kysdaddy,

Rockstor plugins are based on Docker, and only have access to the filesystem objects that are exported to them as volumes.
When you installed the Rockon, you were asked to provide two volumes to be mapped.

/media     - Directory for your downloaded media
/settings  - Holds all the utorrent settings files and databases

In this case, during the installation, you (hopefully) selected the /media location as /mnt2/Rock_TV
If you did this, then inside the utorrent configuration, you must select the path that it has been mapped to - /media and this will resolve the issue.

If you did not do this during the initial install, then your easiest option will be to uninstall and re-install the Rockon with the correct settings.

Thanks for responding, the odd part of this is that my files are being saved in the settings share and the data/media share isn’t being used at all.
I uninstalled and tried it again and the same thing happens. I created two shares UTMedia and UtorrentSettings. UTMedia is empty and UtorrentSettings has settings and the downloaded files.

I even set it up on a different Rockstor device

Here are my current settings.

Here is a screenshot of what I’m seeing on the rockstor

I have uninstalled 3 times and it keeps doing the same thing. I am really at a loss here.

thanks chas

Wait a minute it saving the torrents in settings but I still don’t see the files.


So you’ve configured the utorrent rockon with the share labelled UTMedia to /media

Assuming your utorrent client is correctly configured to download into /media that means your files should be available in /mnt2/UTMedia (The share mapped to /media).
If this is the case, I suggest browsing to /mnt2/UTMedia and having a look.

If your utorrent client is not configured to download into /media, then the files will be stored internally in the Docker image, which is not ideal, and requires some fairly advanced knowledge to get it.

If you want the downloads going to /mnt2/Rock_TV, you need to reinstall utorrent appropriately to use the Rock_TV share instead

1 Like

thank you Haioken for the info. If I am reading this correctly it seems that my Utorent client may not be configured to save in Media? At this point I would be happy if it would save into UTMedia as set in the install settings.
If this is correct what do you suggest I do, is there a way to check where the client is configured to save?
you can see in the photos that I have /UTMedia mapped to /Media so it seems correct yes?

Sorry for all the pictures I just want to be sure that I am being clear

Install settings

Utorrent webUI





Even though I don’t have any experience with this Rock-on, it appears to me that, based on your Rock-on installation screenshot, you have set the UTMedia share defined in Rockstor as the /media folder for the Rock-on.
As a result, in the UT webUI, you should be able to set the folder /media as the download directory. To see (and access) these files from “outside” of the Rock-on, you would simply need to go to /mnt2/UTMedia.

Hope this helps,

Hi @kysdaddy,

As mentioned by @Flox, this needs to be changed in the UTorrent web UI, to set the download location to /media.

I also have little experience with UTorrent, but I believe that you’re looking for Settings -> Folders.
If that doesn’t help you, let me know and I’ll run up a UTorrent instance tonight (AU time) and test if for you

Thanks that’s my understanding as well but unfortunately as you can see in the photos, the files are not showing up where I have mapped them to be. I am at a loss as to where they might be going.
The actual torrent is being saved in settings, until I delete it using the UT UI.

It seems that the actual media files are being saved on my system disk rather than where they are supposed to be . My system disk had grown from 3.07 gb to 28 gb before I uninstalled Utorrent.

I really like Utorrent and it seems like if I could just get this mapping issue corrected it would be great. Please give me any ideas you have.

Haioken, Please do run it up, perhaps if you get it working you can tell me where I am messing up.


Hey @kysdaddy please put a picture of Utorrent config, specifically the directories tab. It’ll be under Settings>Directories.

Thanks for weighing in on this.
The directories tab in the Utorrent UI doesn’t seem to be working for me. I took this screenshot before I clicked on save.

I click on save settings and the main screen loads, I click on the settings gear and Directories tab and this is what I see.

This is the problem, it’s not saving the directories where you’ll be downloading to and this is why it saves it into the UT settings. From memory sometimes the mapped folder doesn’t work correctly try to put this in the “Put new downloads in” field, /media/UTMedia, and empty the 2nd field under then save it and see how it’ll go. If it worked then in the 2nd field replace the /mnt2 with /media. I have stopped using all the rockons since they are very difficult to troubleshoot, but I am happy to enable them and reinstall the Utorrent and try it to tell you exactly what you need to do.

Well I tried the entrys that you suggest but it doesn’t look like it is sticking, the directories tab is still blank but now the media file is ending up in UTSettings

Are you saying that “Move completed files to” should be /Media/Acer_tv ?


Your configuration is attempting to put the files into directories that are not exported to the docker container.

Your configuration should be:

[*] Put new downloads in: /media
[ ] Move completed downloads to: <blank>

The inside of your docker container is not your local filesystem.

the paths you can normally see are not available to it, only the paths exported to it are (/media and /settings), and the paths that created inside the docker image.

Please disable the ‘move completed downloads’ option, and set the ‘Put new downloads in’ option to /media and try again.

1 Like

As @Haioken mentioned disable “Move completed downloads” by unticking the box. Just try to add /media/Acer_tv in the “Put new downloads in”

/media is the default location for the your downloaded data, it meant to be mapped during the initial setup and you add your own directory, but sometimes this mapping representation doesn’t work properly. Once I get home I will install the rockon and will see how I used to use it :slight_smile:.

[quote=“Haioken, post:15, topic:4695”]
OK that got it, the file is now in the Media folder 8^)

Can I now use the “Move completed downloads to:” an additional storage Acer_tv = /data/Media?

Yes you can, just enable the 2nd field in the directories of Utorrent and make sure to add /media/yourpath. Basically the /media is a substitute for the /mnt2. Your new path will be /media/Acer_tv, I am not sure if this path is a share or not?

Yes, thank you so much. I went ahead and tied it and it worked.
I can’t thank you both too much Mahmoud and Haioken!
You guys are great!

1 Like


Yup, no problems with that as long as you specify the correct directory (/data/media) in the ‘Rockon Directory’ section of the rockon add storage option.


I’ve seen no instances where the mapped representation has not performed as expected, and I have tested UTorrent myself (just now, over my OpenVPN connection) to verify, and /media correctly maps to the appropriate share location.
I have just tested it myself, and it works fine.

Further to that, in his latest post, I believe @kysdaddy was referring to using Rockons -> Utorrent -> Settings -> Add Storage to map his local ‘Acer_TV’ share to his Rockstor instance, with the Rockon directory as /data/media