Samba could not be configured. Try again. Exception: 'workgroup'

I performed a fresh install of RockStor and am now configuring access to it from my Windows 10 desktop,

Went to setup SAMBA, entered the workgroup name and received the following

Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/smart_manager/views/”, line 83, in post
update_global_config(global_config, adconfig)
File “/opt/rockstor/src/rockstor/system/”, line 134, in update_global_config
tfo.write(’ %s = %s\n’ % (k, ad_config[k]))
KeyError: 'workgroup’

Tried it again. Same. Tried it with a different workgroup name to see if there was legacy conflict - same.

Good morning @William212,
please read this post

Message n. 6 explains how to solve it :slight_smile:

Sorry again for this, it’s just a missing patch over 3.8.15 (@suman we need it asap at least on testing channel :slight_smile: )


Thanks! download worked fine but “patch” resulted in “command not found”

Ran “help” and didn’t see “patch” as an option.


@Flyer the testing channel already has this fix :slight_smile:

@William212 please enable testing channel and update to newest version, this should get you going again. Let the automation fix this for you :slight_smile:

ps. it’s @Flyer f*** up so if you want to join the angry mob with torches and pitch forks, I’m responsible for sign ins :fire: :smiley:

1 Like

Done and after some fidgeting around - remembering to setup the shares, ownership, etc, I’m back up!


At what point do I switch back to Stable updates?

1 Like

Please stay on testing till next testing,
there’s a pending PR for modal services configuration required (my fault once again, mixed some code while testing :/)


1 Like

@William212 and @Flyer I think @suman stated an interest in getting to the next stable release quite quickly on this current testing run, or rather more in keeping with the usual time frames. The last testing channel updates was rather long so a return to norm is planned. Seem to remember some public speak of towards the end of this month, but can’t find the reference I’m afraid.

There will be a fresh forum post announcing the new stable release so we can just link to that form this thread when the time comes.


That’s the plan @phillxnet.

1 Like