[SOLVED] Unknown internal error doing a POST to /api/rockons/update and popup does not display any code

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Unable to execute update for rock-ons so the list won’t populate.

Detailed step by step instructions to reproduce the problem

Fresh installation, tried the command via webUI and the pop up appears after 3 minutes.
Tried to yum update and the issue remains. I don’t receive any errors during update.
Server is a HP N36L with 4Gb RAM running on a 250Gb 2.5" HDD.
I have an another one, identical, that does not have such problem. I’ve tried reinstalling over other HDD, but the issue remains.
I even tried on a completely different machine, HP ML110 G5, same result.
I tried to upload the configuration file from the working one but it does not work

Web-UI screenshot


Error Traceback provided on the Web-UI

there is NO code on the webUI error popup.

@Darkest, welcome to the Rockstor Community. Did you happen to check out this post, it looks like they had a similar no coding message with the same components (/api/rockons/update).

None of that might of course apply to you and you’ve tried that already.

On a side note, if you haven’t found the search function on this forum, the header bar is a little bit funky, if you hover near your name avatar, then the looking glass will show up, like this:



Thanks, the answer was in that thread.
For whatever reason wget wasn’t installed on ANY of my Rockstors, except for the very first working one.
I used a PiHole too, but it was disabled during my tests to be sure that it wouldn’t block anything.

Solved by installing wget…


glad to hear that it worked out! Would you mind adding [Solved] in front of your post, so the next person can quickly identify what might work for them?


1 Like

Hello there,

I have the same issue and cannot get rid of it no matter what I do.

Looking at that other thread I found that the system has no wget installed. But when trying to dnf or yum update, the system complains:

I also have a PiHole but it is discarded since the system can resolve external domains.

It may sound a bit dumb but cannot figure out easily how to feed the repolist or what is the best take on this.

Can you help me out?

To update the repos state on a v4 “Built on openSUSE” variant you must use zypper. We do have installed dnf and yum but they are not canonical and they are there for historical reasons and to get info on future changelog entries which zypper can’t currently do. So stick to zypper for all your own interactions.

From our installer how-to subsection here:
we have:

Welcome to Rockstor built on openSUSE.
To update your system from here do:

        zypper refresh
        zypper up --no-recommends

Or use Rockstor's Web User Interface (Web-UI): recommended method.

If you are currently running our 4.0.9-0 Leap 15.3 based install subscribed to Stable then you will have a cosmetic error and the stable repo will be ignored. That is because it is not yet populated. We haven’t yet reached v4 Stable so have no repository for it. But very soon is the hope. But zypper will just ignore this repo untill it does exist. To avoid this inconvenience you can subscribe to testing and only update all but the rockstor package via the Web-UI. See the following doc section for how this is done:


We did populate our 15.2 stable repository with a 4.0.4 but that was to rule out an issue we were having at the time with zypper that is now sorted.

Apologies for this rough edge. In the future we will not be in this position as we will always have the prior stable rpm. But as the v4 is yet to reach it’s first stable release we are in a corner of sorts.

Like wise if you then need to install wget you would use

zypper in wget

But you shouldn’t need it actually. The ‘in’ is short for ‘install’. And in openSUSE zypper is the go-to for package management.

Hope that helps.

1 Like


This is a good quick reference for zypper:

In case you find yourself at a loose end re zypper. Again all normal updates are best done from the Web-UI but it’s good to know just in case. And we find ourselves between a rock and a hard place with this first v4 stable release.

1 Like

Hey Phill,

Sorry for my late reply as I was very busy with other matters and left the NAS thing a bit appart until now.

The info you provided is much appreciated!

1 Like