Stable Updates/Subscription not working (still)

Registered for Stable a while back, during the old Store to new OpenCollective move - no registration code arrived in the inbox. Advised to wait a bit and the new system would help sort this out.

Figured I’d try again now that the move to the OpenCollective has been completed. :slight_smile: Submitted a second registration and payment for Stable. Still no email/registration code, still stuck in Testing. According to Appman, the old/first subscription is still active (8 months left) but the second one didn’t make an appearance, which is both good and bad.

I’ve made use of Rockstor for quite a while, and I’m happy to support and to continue to support the project - you guys do great work and it’s appreciated.

I’d just like to get my little home NAS moved onto the Production string at some point. Any advice welcome. :smiley:



Hi @KeithF ,

Sorry to read there have been some issues there. I’ll open a private message with you and @phillxnet shortly here on the forum to get all of that situated :slight_smile: .

1 Like

@KeithF Thanks again, in public this time, for the report here.

I’m updating my progress on this issue in the Private Message @Flox started.

I will likely do a public announcement on the resolution once it’s in place. But I don’t think the later half of your experience has yet affected anyone else. The former half is explained in the Private Message. Your activation code was carried over from a previously unexpired order (grace period).

Just wanted to publicly acknowledge this in case you had not received notification of the new PM setup by @Flox.

To anyone else concerned with this report: me and Flox are now fully aware of exactly why this repeat membership subscription was not acknowledged by Appman. But it was logged and is now understood. I will be creating a test based on this failure point and work against that test towards a fix.

In short we didn’t get an Open Collective WebHook that we expected: ergo adaptation afoot.

But we did get a fall-back option we have already partially prepared for. There are, as yet, not that many examples of working this way with Open Collective so we are rather having to find our own feet on this one. Nearly there however.

Currently new Stable Updates subscription memberships are being processed as intended. and have worked as intended from the get-go.

All good, and as with all our elements within ‘The Rockstor Project’ bug reports are always welcome.

1 Like

While bumbling around looking for the current testing channel thread, I stumbled on this. First question: where’s the thread with info on updating from Rockstor 4.1 & Leap 5.3.18? I know there’s a long testing thread here someplace…

I also noticed the reference to Open Collective above and now see the link on the tool bar. At first I thought “What the heck? Did they start a Kibbutz?” but now I see you’ve replaced the store. Good - it’s about time - I’ve been freeloading since the old store broke.

@wdc Hello again.
I’ll answer this in place, but it likely would have been better in a thread of it’s own really :).


Not quite sure what this means actually, but I’m assuming you are referencing updating from the last Stable of 4.1.0-0:

with a ‘Built on/Uses’ base OS of Leap 15.3, to a newer Rockstor instance: Stable or otherwise.

From the forum thread for the next stable release 4.6.1-0:

Note the following:
Released in Stable Channel updates on 18th July 2023.
Leap 15.4 & Tumbleweed.

So if you are asking why no new Stable, and you are still on a Leap 15.3 base, it’s because it was released for Leap 15.4 only as 15.3 was EOL for over 6 months by that point: however we did release testing channel versions for Leap 15.3 base OS to get folks there to newer versions in order to help with existing installs not being left too far behind. But the official 4.6.1-0 stable rpm was only published for 15.4 (but it first appeared, as all our Stable rpms do, in a prior testing channel (just saying)). And for the 15.3 base it was the last in that stable channel. But do take care to not go further than that version if you want to be using the stable rpms. We have now begun a new testing channel phase that includes 15.4 onwards as an OS base.

So it may be that the following howto in our docs is relevant:
But if you are still on a “Uses OpenSUSE Leap 15.2” based install then follow the 15.2 to 15.3 in-place update first:

Mouse over on the kernel version in top-right of Web-UI should tell you what base OS your Rockstor install is based on:
or for say our Leap 15.5 based testing rpm releases we have (a slightly out-of-date):


We haven’t reached the next stable for Leap 15.5 yet however - that is what our current testing channel is aimed at.

Or a peek via cat /etc/os-release at the canonical reference of course.

Hope that helps.