Unable to delete rock-ons-root directory

Brief description of the problem

I ran into some issues where OwnCloud rock-on is stuck on installing state for couple of days now. I have tried to remove the container that was created but still stuck on “Installing” state. After reading around I have finally decided to delete rock-ons-root which includes the Plex rock-on that was working okay. However, I am getting below error. Could someone help please. I am new to both rockstor and linux

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/storageadmin/views/share.py", line 381, in delete remove_share(share.pool, share.subvol_name, share.pqgroup, force=force) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1026, in remove_share run_command([BTRFS, "subvolume", "delete", subvol], log=True) File "/opt/rockstor/src/rockstor/system/osi.py", line 227, in run_command raise CommandException(cmd, out, err, rc) CommandException: Error running a command. cmd = /usr/sbin/btrfs subvolume delete /mnt2/ROOT/@/rock-ons-root/btrfs/subvolumes/5330a56e5b736e0cd739be014e3869b877fb32bf566e266c4ad87e2c8765d81f. rc = 1. stdout = ['']. stderr = ['ERROR: Could not statfs: No such file or directory', '']

@ManiV welcome to the Rockstor community.

I would first start with trying to get rid of the OwnCloud rockon. Since you’re new to Linux, I assume, you are not using an external client like PuTTY to log into the system (using the root user) for using the command line.

You could use the Shellinabox feature on Rockstor by clicking on the System Shell icon:


In order to execute the deletion you will need administrator access. So, as @phillxnet outlined here:

log in with the WebUI user when asked and then elevate to the root user from that account by

su -

it will ask for the password you created for the root user during the installation of Rockstor.
Once that’s taken care of continue with:

cd /opt/rockstor/
poetry run delete-rockon "OwnCloud"

this should take care of removing any remnants of the failed OwnCloud installation.

If you want to to still attempt to remove the Rock-on root share, make sure that the Rock-on service is turned off before you delete it.


Thank you so much @Hooverdan that seemed to have resolved the issue. Much appreciated.