Plex Updates (How do I update it )

I have been trying to update Plex my system is currently on version:
at the moment the latest version is version:

I uninstalled it in rockons rebooted and reinstalled after hitting the update button an it’s still
on the same old version, I’m I doing something wrong ? How do you update plex server ?

please advise


BTW I love Rockstor and it’s been working great for me…

@painkiller895 Hello again and a very very belated welcome to the Rockstor community forum.

Please see my response to a similar question just now and let us know if that helps?

Glad you are enjoying Rockstor and thanks for saying so, nice to hear.

Thanks for the response, I reinstalled it again and also put the latest and it did not update.
still on the old version. :frowning:
Might be the permissions not letting it up date ? I did make a Plex user in the admin group also there is no password or login set on this account and it has it’s own PID number also.

I have no idea what it might be…

@painkiller895 OK, have you also tried after your server is registered with a Plex account.
See post:

Let us know if that helps in your setup.

See the settings (spanners icon top right in Plex Rock-on WebUI) - Server page.

@painkiller895 Just posted my last reply as you were editing your last reply.

You might also want to take a look at our: Plex Server Rock-on doc entry:

It deals with the user and share permissions config for the Plex rockon install.

I checked everything, all looks good. Just as the Docs say…
Still will not update after I reinstalled it again…

I also checked this and all looks good…

For me the autoupdate work (most of the time).
First make sure the plex service is signed in with your plex account.
Stop the rockon from the rockstor interface.
Restart it and wait a bit for the service to become available.

This will update plex on my system.

Tried it all, still not updating…

docker rmi -f linuxserver/plex
I like an idiot issued this command and now I can’t log into my rockstor not getting a connection.
I was able to get in via ssh and log in as root.

How can I get my system back ??? Re-install ? I have 6 TB of stuff on there I don’t want to loose
please help…
I have no GUI can login only to ssh


did you uninstall plex from rockstor page first?

I guess you didn’t :slight_smile:

What you can try is the following from ssh:
docker pull linuxserver/plex

This will redownload the plex image. After that run this:
docker ps

It will show running containers. like this for my box:# docker ps

30c3dc18b951 linuxserver/sabnzbd “/init” 21 hours ago Up 21 hours>9090/tcp,>8080/tcp sabnzb
59d10124acb4 4737cca51096 “/init” 3 days ago Up 22 hours
9247cb8df092 6cee52827bdd “/init” 3 days ago Up 28 minutes>8181/tcp,>8181/udp
46d6ccdf81cb a165d6f35451 “/init” 3 days ago Up 21 minutes>8989/tcp Sonarr
fb17c062d08a 353dc75755bb “/init” 3 days ago Up 15 minutes>7878/tcp radarr

If you see plex running there do this:
docket stop

After that try to start it with:
docker start

No I just turned it off and login to ssh and issued the command… I rebooted and got no GUI not able to make a connection via web browser, Only SSH and I able to connect via samba to my files also.
Just no GUI. I can’t login to my rockstor system via web browser…

Well try the commands i had listed above.
After that if you still do not have GUI just issue a reboot command from SSH.
The image should start up fine after the image is pulled again.

I must have broke my system I can’t login to it via web browser…

did you run the commands i listed in above post using SSH?

BRB going out to lunch…
thanks for the reply
20 min later

I’m back

I issued all the commands you listed this is what I get:
I also rebooted the system after pulling plex …

[root@RockstorC24 ~]# docker ps
15266288cd30 timhaak/plex “/” 17 months ago Up About a minute plex
[root@RockstorC24 ~]# docker ps
15266288cd30 timhaak/plex “/” 17 months ago Up 3 minutes plex
[root@RockstorC24 ~]# docket stop
-bash: docket: command not found
[root@RockstorC24 ~]# docker stop
Error response from daemon: no such id:
Error: failed to stop containers: []
[root@RockstorC24 ~]#

This is what I get

but the strange thing is that plex server is running I see it when I connect to it via my tv.

In your case, your Plex container has the name plex so I would replace with plex:
docker stop plex

It also looks like you’re using a different docker image for Plex than the one by, so the update process detailed by others may not apply.

[root@RockstorC24 ~]# docker stop plex
[root@RockstorC24 ~]# docker start plex
[root@RockstorC24 ~]# docker ps
15266288cd30 timhaak/plex “/” 17 months ago Up 13 seconds plex
[root@RockstorC24 ~]#

Also it’s still stuck on the old version…

Is there a command to get my GUI back on the system, I can’t login via web browser to my rocstor system.

That is so strange… you have the wrong image.
Your image is “timhaak/plex” the correct image is "linuxserver/plex"
Did you do any manual installation of that image?

The rockon config file have the correct infomration:
“Plex”: {
“containers”: {”: {
“image”: “linuxserver/plex”,